Fedora 7 : inotify-tools-3.11-1.fc7 (2007-3074)

Medium Nessus Plugin ID 28160


The remote Fedora host is missing a security update.


A vulnerability has been reported in inotify-tools, which can potentially be exploited by malicious users to compromise an application using the library.

Successful exploitation may allow the execution of arbitrary code with privileges of the application using the affected library.

NOTE: The programs shipped with inotify-tools are reportedly not affected.

The vulnerability is reported in versions prior to 3.11.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected inotify-tools, inotify-tools-debuginfo and / or inotify-tools-devel packages.

See Also



Plugin Details

Severity: Medium

ID: 28160

File Name: fedora_2007-3074.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2007/11/12

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:inotify-tools, p-cpe:/a:fedoraproject:fedora:inotify-tools-debuginfo, p-cpe:/a:fedoraproject:fedora:inotify-tools-devel, cpe:/o:fedoraproject:fedora:7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2007/11/09

Reference Information

CVE: CVE-2007-5037

FEDORA: 2007-3074

CWE: 119