Ubuntu 6.10 / 7.04 : hplip vulnerability (USN-530-1)

High Nessus Plugin ID 28135


The remote Ubuntu host is missing one or more security-related patches.


It was discovered that the hpssd tool of hplip did not correctly handle shell meta-characters. A local attacker could exploit this to execute arbitrary commands as the hplip user.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 28135

File Name: ubuntu_USN-530-1.nasl

Version: $Revision: 1.14 $

Type: local

Agent: unix

Published: 2007/11/10

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Temporal Score: 6.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:hpijs, p-cpe:/a:canonical:ubuntu_linux:hpijs-ppds, p-cpe:/a:canonical:ubuntu_linux:hplip, p-cpe:/a:canonical:ubuntu_linux:hplip-data, p-cpe:/a:canonical:ubuntu_linux:hplip-dbg, p-cpe:/a:canonical:ubuntu_linux:hplip-doc, cpe:/o:canonical:ubuntu_linux:6.10, cpe:/o:canonical:ubuntu_linux:7.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/10/12

Exploitable With

CANVAS (D2ExploitPack)

Core Impact

Metasploit (HPLIP hpssd.py From Address Arbitrary Command Execution)

Reference Information

CVE: CVE-2007-5208

BID: 26054

OSVDB: 41693

USN: 530-1

CWE: 20