Ubuntu 6.06 LTS / 6.10 : gdm vulnerability (USN-396-1)

Medium Nessus Plugin ID 27982


The remote Ubuntu host is missing a security-related patch.


A format string vulnerability was discovered in the gdmchooser component of the GNOME Display Manager. By typing a specially crafted host name, local users could gain gdm user privileges, which could lead to further account information exposure.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected gdm package.

Plugin Details

Severity: Medium

ID: 27982

File Name: ubuntu_USN-396-1.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2007/11/10

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:L/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:gdm, cpe:/o:canonical:ubuntu_linux:6.06:-:lts, cpe:/o:canonical:ubuntu_linux:6.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2006/12/14

Vulnerability Publication Date: 2006/12/14

Reference Information

CVE: CVE-2006-6105

OSVDB: 30848

USN: 396-1