Ubuntu 5.10 / 6.06 LTS / 6.10 : texinfo vulnerability (USN-379-1)

Medium Nessus Plugin ID 27961

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

Miloslav Trmac discovered a buffer overflow in texinfo's index processor. If a user is tricked into processing a .texi file with texindex, this could lead to arbitrary code execution with user privileges.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected info and / or texinfo packages.

See Also

https://usn.ubuntu.com/379-1/

Plugin Details

Severity: Medium

ID: 27961

File Name: ubuntu_USN-379-1.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2007/11/10

Updated: 2018/12/01

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:info, p-cpe:/a:canonical:ubuntu_linux:texinfo, cpe:/o:canonical:ubuntu_linux:5.10, cpe:/o:canonical:ubuntu_linux:6.06:-:lts, cpe:/o:canonical:ubuntu_linux:6.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/11/09

Reference Information

CVE: CVE-2006-4810

BID: 20959

USN: 379-1