Ubuntu 5.04 / 5.10 / 6.06 LTS : gimp vulnerability (USN-312-1)

Medium Nessus Plugin ID 27887


The remote Ubuntu host is missing one or more security-related patches.


Henning Makholm discovered that gimp did not sufficiently validate the 'num_axes' parameter in XCF files. By tricking a user into opening a specially crafted XCF file with Gimp, an attacker could exploit this to execute arbitrary code with the user's privileges.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 27887

File Name: ubuntu_USN-312-1.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2007/11/10

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:gimp, p-cpe:/a:canonical:ubuntu_linux:gimp-data, p-cpe:/a:canonical:ubuntu_linux:gimp-dbg, p-cpe:/a:canonical:ubuntu_linux:gimp-helpbrowser, p-cpe:/a:canonical:ubuntu_linux:gimp-python, p-cpe:/a:canonical:ubuntu_linux:gimp-svg, p-cpe:/a:canonical:ubuntu_linux:gimp1.2, p-cpe:/a:canonical:ubuntu_linux:libgimp2.0, p-cpe:/a:canonical:ubuntu_linux:libgimp2.0-dev, p-cpe:/a:canonical:ubuntu_linux:libgimp2.0-doc, cpe:/o:canonical:ubuntu_linux:5.04, cpe:/o:canonical:ubuntu_linux:5.10, cpe:/o:canonical:ubuntu_linux:6.06:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/07/10

Vulnerability Publication Date: 2006/07/06

Reference Information

CVE: CVE-2006-3404

BID: 18877

OSVDB: 27037

USN: 312-1