Ubuntu 5.10 : libmms vulnerability (USN-309-1)

Medium Nessus Plugin ID 27884


The remote Ubuntu host is missing one or more security-related patches.


Several buffer overflows were found in libmms. By tricking a user into opening a specially crafted remote multimedia stream with an application using libmms, a remote attacker could overwrite an arbitrary memory portion with zeros, thereby crashing the program.

In Ubuntu 5.10, this affects the GStreamer MMS plugin (gstreamer0.8-mms). Other Ubuntu releases do not support this library.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected libmms-dev and / or libmms0 packages.

Plugin Details

Severity: Medium

ID: 27884

File Name: ubuntu_USN-309-1.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2007/11/10

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:libmms-dev, p-cpe:/a:canonical:ubuntu_linux:libmms0, cpe:/o:canonical:ubuntu_linux:5.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2006/07/06

Vulnerability Publication Date: 2006/06/19

Reference Information

CVE: CVE-2006-2200

OSVDB: 26767

USN: 309-1