Ubuntu 5.04 / 5.10 / 6.06 LTS : openldap2, openldap2.2 vulnerability (USN-305-1)

Medium Nessus Plugin ID 27880


The remote Ubuntu host is missing one or more security-related patches.


When processing overly long host names in OpenLDAP's slurpd replication server, a buffer overflow caused slurpd to crash.

If an attacker manages to inject a specially crafted host name into slurpd, this might also be exploited to execute arbitrary code with slurpd's privileges; however, since slurpd is usually set up to replicate only trusted machines, this should not be exploitable in normal cases.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 27880

File Name: ubuntu_USN-305-1.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2007/11/10

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:ldap-utils, p-cpe:/a:canonical:ubuntu_linux:libldap-2.2-7, p-cpe:/a:canonical:ubuntu_linux:libldap2, p-cpe:/a:canonical:ubuntu_linux:libldap2-dev, p-cpe:/a:canonical:ubuntu_linux:libslapd2-dev, p-cpe:/a:canonical:ubuntu_linux:slapd, cpe:/o:canonical:ubuntu_linux:5.04, cpe:/o:canonical:ubuntu_linux:5.10, cpe:/o:canonical:ubuntu_linux:6.06:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2006/06/27

Vulnerability Publication Date: 2006/05/19

Reference Information

CVE: CVE-2006-2754

OSVDB: 25659

USN: 305-1