GLSA-200711-02 : OpenSSH: Security bypass

High Nessus Plugin ID 27612

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200711-02 (OpenSSH: Security bypass)

Jan Pechanec discovered that OpenSSH uses a trusted X11 cookie when it cannot create an untrusted one.
Impact :

An attacker could bypass the SSH client security policy and gain privileges by causing an X client to be treated as trusted.
Workaround :

There is no known workaround at this time.

Solution

All OpenSSH users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/openssh-4.7'

See Also

https://security.gentoo.org/glsa/200711-02

Plugin Details

Severity: High

ID: 27612

File Name: gentoo_GLSA-200711-02.nasl

Version: 1.17

Type: local

Published: 2007/11/02

Updated: 2018/07/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openssh, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/11/01

Reference Information

CVE: CVE-2007-4752

BID: 25628

GLSA: 200711-02

CWE: 20