ProFTPD < 1.3.0a Multiple Vulnerabilities

critical Nessus Plugin ID 27055
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote FTP server is affected by several vulnerabilities.


The remote host is using ProFTPD, a free FTP server for Unix and Linux.

According to its banner, the version of ProFTPD installed on the remote host is earlier than 1.3.0a. As such, it may be affected by one or more of the following vulnerabilities :

- An off-by-one string manipulation flaw exists in the 'sreplace' function. (CVE-2006-5815)

- A buffer overflow exists in the 'tls_x509_name_oneline' function of the mod_tls module involving the data length argument. (CVE-2006-6170)

- An off-by-two buffer overflow exists due to a failure to properly set the buffer size limit when 'CommandBufferSize' is specified in the configuration file, an issue which is disputed by the developers.

An attacker may be able to leverage this issue to crash the affected service or execute arbitrary code remotely, subject to the privileges under which the application operates.


Upgrade to ProFTPD version 1.3.0a or later.

See Also

Plugin Details

Severity: Critical

ID: 27055

File Name: proftpd_1_3_0_a.nasl

Version: 1.24

Type: remote

Family: FTP

Published: 10/15/2007

Updated: 11/15/2018

Dependencies: ftpserver_detect_type_nd_version.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: High

Score: 7.4


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:proftpd:proftpd:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport, ftp/proftpd

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 11/10/2006

Exploitable With

Metasploit (ProFTPD 1.2 - 1.3.0 sreplace Buffer Overflow (Linux))

Reference Information

CVE: CVE-2006-5815, CVE-2006-6170, CVE-2006-6171

BID: 20992

CWE: 119