GLSA-200710-12 : T1Lib: Buffer overflow

High Nessus Plugin ID 27047


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200710-12 (T1Lib: Buffer overflow)

Hamid Ebadi discovered a boundary error in the intT1_EnvGetCompletePath() function which can lead to a buffer overflow when processing an overly long filename.
Impact :

A remote attacker could entice a user to open a font file with a specially crafted filename, possibly leading to the execution of arbitrary code with the privileges of the user running the application using T1Lib.
Workaround :

There is no known workaround at this time.


All T1Lib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/t1lib-5.0.2-r1'

See Also

Plugin Details

Severity: High

ID: 27047

File Name: gentoo_GLSA-200710-12.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/10/15

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:t1lib, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/10/12

Vulnerability Publication Date: 2007/07/27

Reference Information

CVE: CVE-2007-4033

OSVDB: 38698

GLSA: 200710-12

CWE: 119