Winamp < 5.5 FLAC Plug-in Multiple Buffer Overflows

High Nessus Plugin ID 27040

Synopsis

The remote Windows host contains a multimedia application that is affected by multiple buffer overflow vulnerabilities.

Description

The remote host is using Winamp, a popular media player for Windows.

The version of Winamp installed on the remote Windows host contains a plug-in to handle playing FLAC files that contains several integer buffer overflow vulnerabilities. If an attacker can trick a user on the affected host into opening a specially crafted FLAC file, he may be able to leverage this issue to execute arbitrary code on the host subject to the user's privileges.

Solution

Either upgrade to Winamp version 5.5 or later or remove the FLAC Input Plug-in (in_flac.dll).

See Also

http://www.nessus.org/u?674b263e

https://www.securityfocus.com/archive/1/482115/30/0/threaded

http://www.winamp.com/player/version-history

http://forums.winamp.com/showthread.php?threadid=278538

Plugin Details

Severity: High

ID: 27040

File Name: winamp_55.nasl

Version: 1.19

Type: local

Agent: windows

Family: Windows

Published: 2007/10/12

Updated: 2018/11/15

Dependencies: 13855, 15817, 10456

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Required KB Items: SMB/Winamp/Version, SMB/Winamp/Path, SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2007-4619

BID: 26042

CWE: 189