GLSA-200710-03 : libvorbis: Multiple vulnerabilities

Medium Nessus Plugin ID 26943


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200710-03 (libvorbis: Multiple vulnerabilities)

David Thiel of iSEC Partners discovered a heap-based buffer overflow in the _01inverse() function in res0.c and a boundary checking error in the vorbis_info_clear() function in info.c (CVE-2007-3106 and CVE-2007-4029). libvorbis is also prone to several Denial of Service vulnerabilities in form of infinite loops and invalid memory access with unknown impact (CVE-2007-4065 and CVE-2007-4066).
Impact :

A remote attacker could exploit these vulnerabilities by enticing a user to open a specially crafted Ogg Vorbis file or network stream with an application using libvorbis. This might lead to the execution of arbitrary code with privileges of the user playing the file or a Denial of Service by a crash or CPU consumption.
Workaround :

There is no known workaround at this time.


All libvorbis users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/libvorbis-1.2.0'

See Also

Plugin Details

Severity: Medium

ID: 26943

File Name: gentoo_GLSA-200710-03.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/10/09

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libvorbis, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/10/07

Vulnerability Publication Date: 2007/07/25

Reference Information

CVE: CVE-2007-3106, CVE-2007-4029, CVE-2007-4065, CVE-2007-4066

OSVDB: 38675, 38676, 38677, 38678, 38679

GLSA: 200710-03

CWE: 119, 399