Mandrake Linux Security Advisory : t1lib (MDKSA-2007:189)

High Nessus Plugin ID 26899


The remote Mandrake Linux host is missing one or more security updates.


A buffer overflow vulnerability was discovered in t1lib due to improper bounds checking. An attacker could send specially crafted input to an application linked against t1lib which could lead to a denial of service or the execution of arbitrary code.

Updated packages have been patched to prevent this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 26899

File Name: mandrake_MDKSA-2007-189.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/10/03

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64t1lib5, p-cpe:/a:mandriva:linux:lib64t1lib5-devel, p-cpe:/a:mandriva:linux:lib64t1lib5-static-devel, p-cpe:/a:mandriva:linux:libt1lib5, p-cpe:/a:mandriva:linux:libt1lib5-devel, p-cpe:/a:mandriva:linux:libt1lib5-static-devel, p-cpe:/a:mandriva:linux:t1lib-config, p-cpe:/a:mandriva:linux:t1lib-progs, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/09/27

Reference Information

CVE: CVE-2007-4033

BID: 25079

MDKSA: 2007:189

CWE: 119