GLSA-200709-13 : rsync: Two buffer overflows

Medium Nessus Plugin ID 26103


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200709-13 (rsync: Two buffer overflows)

Sebastian Krahmer from the SUSE Security Team discovered two off-by-one errors in the function 'f_name()' in file sender.c when processing overly long directory names.
Impact :

A remote attacker could entice a user to synchronize a repository containing specially crafted directories, leading to the execution of arbitrary code with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All rsync users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/rsync-2.6.9-r3'

See Also

Plugin Details

Severity: Medium

ID: 26103

File Name: gentoo_GLSA-200709-13.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2007/09/24

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:rsync, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/09/20

Reference Information

CVE: CVE-2007-4091

OSVDB: 39592

GLSA: 200709-13