GLSA-200709-08 : id3lib: Insecure temporary file creation

High Nessus Plugin ID 26098


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200709-08 (id3lib: Insecure temporary file creation)

Nikolaus Schulz discovered that the function RenderV2ToFile() in file src/tag_file.cpp creates temporary files in an insecure manner.
Impact :

A local attacker could exploit this vulnerability via a symlink attack to overwrite arbitrary files.
Workaround :

There is no known workaround at this time.


All id3lib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/id3lib-3.8.3-r6'

See Also

Plugin Details

Severity: High

ID: 26098

File Name: gentoo_GLSA-200709-08.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/09/24

Modified: 2016/05/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:id3lib, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/09/15

Reference Information

CVE: CVE-2007-4460

BID: 25372

OSVDB: 39631

GLSA: 200709-08