Mandrake Linux Security Advisory : fetchmail (MDKSA-2007:179)

Medium Nessus Plugin ID 26046


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability in fetchmail was found where it could crash when attempting to deliver an internal warning or error message through an untrusted or compromised SMTP server, leading to a denial of service.

Updated packages have been patched to prevent these issues.


Update the affected fetchmail, fetchmail-daemon and / or fetchmailconf packages.

Plugin Details

Severity: Medium

ID: 26046

File Name: mandrake_MDKSA-2007-179.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/09/14

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:fetchmail, p-cpe:/a:mandriva:linux:fetchmail-daemon, p-cpe:/a:mandriva:linux:fetchmailconf, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/09/11

Reference Information

CVE: CVE-2007-4565

MDKSA: 2007:179