GLSA-200709-02 : KVIrc: Remote arbitrary code execution

High Nessus Plugin ID 26042


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200709-02 (KVIrc: Remote arbitrary code execution)

Stefan Cornelius from Secunia Research discovered that the 'parseIrcUrl()' function in file src/kvirc/kernel/kvi_ircurl.cpp does not properly sanitise parts of the URI when building the command for KVIrc's internal script system.
Impact :

A remote attacker could entice a user to open a specially crafted irc:// URI, possibly leading to the remote execution of arbitrary code with the privileges of the user running KVIrc. Successful exploitation requires that KVIrc is registered as the default handler for irc:// or similar URIs.
Workaround :

There is no known workaround at this time.


All KVIrc users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-irc/kvirc-3.2.6_pre20070714'

See Also

Plugin Details

Severity: High

ID: 26042

File Name: gentoo_GLSA-200709-02.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/09/14

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:kvirc, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/09/13

Vulnerability Publication Date: 2007/06/26

Reference Information

CVE: CVE-2007-2951

OSVDB: 37604

GLSA: 200709-02