Apache 2.2.x < 2.2.6 Multiple Vulnerabilities (DoS, XSS, Info Disc)

medium Nessus Plugin ID 26023


The remote web server is affected by multiple vulnerabilities.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.6. It is, therefore, affected by the following vulnerabilities :

- A denial of service vulnerability in mod_proxy.
- A cross-site scripting vulnerability in mod_status.
- A local denial of service vulnerability associated with the Prefork MPM module.
- An information leak in mod_cache.
- A denial of service vulnerability in mod_cache.

In addition, it offers a workaround for a cross-site scripting issue in mod_autoindex.

Note that the remote web server may not actually be affected by these vulnerabilities. Nessus did not try to determine whether any of the affected modules are in use on the remote server or to check for the issues themselves.


Upgrade to Apache version 2.2.6 or later. Alternatively, ensure that the affected modules are not in use.

See Also


Plugin Details

Severity: Medium

ID: 26023

File Name: apache_2_2_6.nasl

Version: 1.41

Type: remote

Family: Web Servers

Published: 9/14/2007

Updated: 6/29/2018

Risk Information


Risk Factor: Medium

Score: 5.2


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2/6/2007

Reference Information

CVE: CVE-2006-5752, CVE-2007-1862, CVE-2007-1863, CVE-2007-3303, CVE-2007-3304, CVE-2007-3847, CVE-2007-4465, CVE-2007-1743

BID: 24215, 24553, 24645, 24649, 25489, 25653

CWE: 79, 94