ER Mapper NCSView ActiveX Multiple Buffer Overflows

High Nessus Plugin ID 26014


The remote Windows host has an ActiveX control that is affected by multiple buffer overflow vulnerabilities.


The remote host contains the 'NCSView' ActiveX control, distributed as part of the ER Mapper package and used to view maps in Internet Explorer.

The version of this control installed on the remote host reportedly contains multiple stack-based buffer overflows. If an attacker can trick a user on the affected host into visiting a specially crafted web page, this issue could be leveraged to execute arbitrary code on the host subject to the user's privileges.


Either disable the use of this ActiveX control from within Internet Explorer by setting its kill bit or upgrade to ER Mapper version 8.1 (version of the NCSView control itself) or later.

Plugin Details

Severity: High

ID: 26014

File Name: er_mapper_ncsview_activex_overflows.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2007/09/10

Modified: 2014/06/03

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2007/09/06

Reference Information

CVE: CVE-2007-4470

BID: 25584

OSVDB: 37780

CERT: 589188

CWE: 119