Apple iTunes < 7.4 Malformed Music File Heap Overflow (credentialed check)

High Nessus Plugin ID 25998


The remote Windows host contains an application that is affected by a remote code execution flaw.


The remote host is running Apple iTunes, a popular media player.

The remote version of iTunes is vulnerable to a heap overflow when it parses a specially crafted MP4/AAC file. By tricking a user into opening such a file, a remote attacker may be able to leverage this issue to execute arbitrary code on the affected host, subject to the privileges of the user running the application.


Upgrade to Apple iTunes 7.4 or later.

See Also

Plugin Details

Severity: High

ID: 25998

File Name: itunes_7_4.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2007/09/07

Modified: 2015/08/03

Dependencies: 25996

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:itunes

Required KB Items: SMB/iTunes/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2007/09/06

Reference Information

CVE: CVE-2007-3752

BID: 25567

OSVDB: 38528

CWE: 119