Debian DSA-1364-2 : vim - several vulnerabilities

high Nessus Plugin ID 25964
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in the vim editor. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2007-2953 Ulf Harnhammar discovered that a format string flaw in helptags_one() from src/ex_cmds.c (triggered through the 'helptags' command) can lead to the execution of arbitrary code.

- CVE-2007-2438 Editors often provide a way to embed editor configuration commands (aka modelines) which are executed once a file is opened. Harmful commands are filtered by a sandbox mechanism. It was discovered that function calls to writefile(), feedkeys() and system() were not filtered, allowing shell command execution with a carefully crafted file opened in vim.

This updated advisory repairs issues with missing files in the packages for the oldstable distribution (sarge) for the alpha, mips, and mipsel architectures.

Solution

Upgrade the vim packages.

For the oldstable distribution (sarge) these problems have been fixed in version 6.3-071+1sarge2. Sarge is not affected by CVE-2007-2438.

For the stable distribution (etch) these problems have been fixed in version 7.0-122+1etch3.

See Also

https://security-tracker.debian.org/tracker/CVE-2007-2953

https://security-tracker.debian.org/tracker/CVE-2007-2438

https://security-tracker.debian.org/tracker/CVE-2007-2438

https://www.debian.org/security/2007/dsa-1364

Plugin Details

Severity: High

ID: 25964

File Name: debian_DSA-1364.nasl

Version: 1.23

Type: local

Agent: unix

Published: 9/3/2007

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.6

Vector: AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:vim, cpe:/o:debian:debian_linux:3.1, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 9/19/2007

Reference Information

CVE: CVE-2007-2438, CVE-2007-2953

DSA: 1364