Oracle JInitiator beans.ocx ActiveX Multiple Buffer Overflows

High Nessus Plugin ID 25951


The remote Windows host has at least one ActiveX control that is affected by several buffer overflow vulnerabilities.


The remote host contains one or more versions of the 'beans.ocx' ActiveX control, distributed as a part of Oracle JInitiator.

The version of at least one of these controls on the remote host reportedly is affected by multiple and as-yet unspecified stack buffer overflows in its initialization parameters. If an attacker can trick a user on the affected host into visiting a specially crafted web page, this issue could be leveraged to execute arbitrary code on the host subject to the user's privileges.


Disable the use of any reported ActiveX controls from within Internet Explorer by setting their kill bits.

See Also

Plugin Details

Severity: High

ID: 25951

File Name: oracle_jinitiator_beans_activex_overflows.nasl

Version: $Revision: 1.23 $

Type: local

Agent: windows

Family: Windows

Published: 2007/08/29

Modified: 2016/11/02

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:W/RC:ND

Vulnerability Information

CPE: cpe:/a:oracle:jinitiator

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2007/08/28

Exploitable With

CANVAS (D2ExploitPack)

ExploitHub (EH-12-300)

Reference Information

CVE: CVE-2007-4467

BID: 25473

OSVDB: 37711

CERT: 474433

CWE: 20