Debian DSA-1358-1 : asterisk - several vulnerabilities

Critical Nessus Plugin ID 25938

Synopsis

The remote Debian host is missing a security-related update.

Description

Several remote vulnerabilities have been discovered in Asterisk, a free software PBX and telephony toolkit. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2007-1306 'Mu Security' discovered that a NULL pointer dereference in the SIP implementation could lead to denial of service.

- CVE-2007-1561 Inria Lorraine discovered that a programming error in the SIP implementation could lead to denial of service.

- CVE-2007-2294 It was discovered that a NULL pointer dereference in the manager interface could lead to denial of service.

- CVE-2007-2297 It was discovered that a programming error in the SIP implementation could lead to denial of service.

- CVE-2007-2488 Tim Panton and Birgit Arkestein discovered that a programming error in the IAX2 implementation could lead to information disclosure.

- CVE-2007-3762 Russell Bryant discovered that a buffer overflow in the IAX implementation could lead to the execution of arbitrary code.

- CVE-2007-3763 Chris Clark and Zane Lackey discovered that several NULL pointer dereferences in the IAX2 implementation could lead to denial of service.

- CVE-2007-3764 Will Drewry discovered that a programming error in the Skinny implementation could lead to denial of service.

Solution

Upgrade the Asterisk packages.

For the oldstable distribution (sarge) these problems have been fixed in version 1.0.7.dfsg.1-2sarge5.

For the stable distribution (etch) these problems have been fixed in version 1:1.2.13~dfsg-2etch1.

See Also

https://security-tracker.debian.org/tracker/CVE-2007-1306

https://security-tracker.debian.org/tracker/CVE-2007-1561

https://security-tracker.debian.org/tracker/CVE-2007-2294

https://security-tracker.debian.org/tracker/CVE-2007-2297

https://security-tracker.debian.org/tracker/CVE-2007-2488

https://security-tracker.debian.org/tracker/CVE-2007-3762

https://security-tracker.debian.org/tracker/CVE-2007-3763

https://security-tracker.debian.org/tracker/CVE-2007-3764

https://www.debian.org/security/2007/dsa-1358

Plugin Details

Severity: Critical

ID: 25938

File Name: debian_DSA-1358.nasl

Version: 1.22

Type: local

Agent: unix

Published: 2007/08/28

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:asterisk, cpe:/o:debian:debian_linux:3.1, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/08/26

Reference Information

CVE: CVE-2007-1306, CVE-2007-1561, CVE-2007-2294, CVE-2007-2297, CVE-2007-2488, CVE-2007-3762, CVE-2007-3763, CVE-2007-3764

DSA: 1358