Mandrake Linux Security Advisory : poppler (MDKSA-2007:161)

Medium Nessus Plugin ID 25893


The remote Mandrake Linux host is missing one or more security updates.


Maurycy Prodeus found an integer overflow vulnerability in the way various PDF viewers processed PDF files. An attacker could create a malicious PDF file that could cause poppler to crash and possibly execute arbitrary code open a user opening the file.

This update provides packages which are patched to prevent these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 25893

File Name: mandrake_MDKSA-2007-161.nasl

Version: $Revision: 1.18 $

Type: local

Published: 2007/08/15

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64poppler-qt1, p-cpe:/a:mandriva:linux:lib64poppler-qt1-devel, p-cpe:/a:mandriva:linux:lib64poppler-qt4-1, p-cpe:/a:mandriva:linux:lib64poppler-qt4-1-devel, p-cpe:/a:mandriva:linux:lib64poppler1, p-cpe:/a:mandriva:linux:lib64poppler1-devel, p-cpe:/a:mandriva:linux:libpoppler-qt1, p-cpe:/a:mandriva:linux:libpoppler-qt1-devel, p-cpe:/a:mandriva:linux:libpoppler-qt4-1, p-cpe:/a:mandriva:linux:libpoppler-qt4-1-devel, p-cpe:/a:mandriva:linux:libpoppler1, p-cpe:/a:mandriva:linux:libpoppler1-devel, p-cpe:/a:mandriva:linux:poppler, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/08/13

Exploitable With

Core Impact

Reference Information

CVE: CVE-2007-3387

BID: 25124

MDKSA: 2007:161

CWE: 189