MS07-044: Vulnerabilities in Microsoft Excel Could Allow Remote Code Execution (940965)

High Nessus Plugin ID 25882


Arbitrary code can be executed on the remote host through Microsoft Excel.


The remote host is running a version of Microsoft Excel that is affected by various flaws that may allow arbitrary code to be run.

To succeed, the attacker would have to send a rogue file to a user of the remote computer and have it open it with Microsoft Excel.


Microsoft has released a set of patches for Excel 2000, XP and 2003.

See Also

Plugin Details

Severity: High

ID: 25882

File Name: smb_nt_ms07-044.nasl

Version: $Revision: 1.28 $

Type: local

Agent: windows

Published: 2007/08/14

Modified: 2017/08/10

Dependencies: 11336, 27524, 57033

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:excel, cpe:/a:microsoft:excel_viewer, cpe:/a:microsoft:office

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/08/14

Vulnerability Publication Date: 2007/08/14

Reference Information

CVE: CVE-2007-3890

BID: 25280

OSVDB: 36383

MSFT: MS07-044

MSKB: 940596, 940601, 940602