Debian DSA-1341-2 : bind9 - design error

Medium Nessus Plugin ID 25851

Synopsis

The remote Debian host is missing a security-related update.

Description

This update provides fixed packages for the oldstable distribution (sarge). For reference the original advisory text :

Amit Klein discovered that the BIND name server generates predictable DNS query IDs, which may lead to cache poisoning attacks.

Solution

Upgrade the BIND packages.

For the oldstable distribution (sarge) this problem has been fixed in version 9.2.4-1sarge3. An update for mips, powerpc and hppa is not yet available, they will be released soon.

For the stable distribution (etch) this problem has been fixed in version 9.3.4-2etch1. An update for mips is not yet available, it will be released soon.

See Also

https://www.debian.org/security/2007/dsa-1341

Plugin Details

Severity: Medium

ID: 25851

File Name: debian_DSA-1341.nasl

Version: 1.19

Type: local

Agent: unix

Published: 2007/08/13

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:bind9, cpe:/o:debian:debian_linux:3.1, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2007/07/25

Reference Information

CVE: CVE-2007-2926

DSA: 1341