Firefox < Multiple Vulnerabilities

High Nessus Plugin ID 25820


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox allows unescaped URIs to be passed to external programs, which could lead to execution of arbitrary code on the affected host subject to the user's privileges, and could also allow privilege escalation attacks against addons that create 'about:blank' windows and populate them in certain ways.


Upgrade to Firefox or later.

See Also

Plugin Details

Severity: High

ID: 25820

File Name: mozilla_firefox_2006.nasl

Version: $Revision: 1.21 $

Type: local

Agent: windows

Family: Windows

Published: 2007/07/31

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/07/30

Vulnerability Publication Date: 2007/07/30

Reference Information

CVE: CVE-2007-3844, CVE-2007-3845, CVE-2007-4041

BID: 25053, 25142

OSVDB: 38026, 38031, 41090, 41188

CWE: 78