RHEL 3 / 4 / 5 : cups (RHSA-2007:0720)

Medium Nessus Plugin ID 25815


The remote Red Hat host is missing one or more security updates.


Updated CUPS packages that fix a security issue in PDF handling are now available for Red Hat Enterprise Linux 3, 4, and 5.

This update has been rated as having important security impact by the Red Hat Security Response Team.

The Common UNIX Printing System (CUPS) provides a portable printing layer for UNIX(R) operating systems.

Maurycy Prodeus discovered an integer overflow flaw in the way CUPS processes PDF files. An attacker could create a malicious PDF file that could potentially execute arbitrary code when printed.

All users of CUPS should upgrade to these updated packages, which contain a backported patch to resolve this issue.


Update the affected packages.

See Also



Plugin Details

Severity: Medium

ID: 25815

File Name: redhat-RHSA-2007-0720.nasl

Version: $Revision: 1.20 $

Type: local

Agent: unix

Published: 2007/07/31

Modified: 2016/12/29

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:cups, p-cpe:/a:redhat:enterprise_linux:cups-devel, p-cpe:/a:redhat:enterprise_linux:cups-libs, p-cpe:/a:redhat:enterprise_linux:cups-lpd, cpe:/o:redhat:enterprise_linux:3, cpe:/o:redhat:enterprise_linux:4, cpe:/o:redhat:enterprise_linux:4.5, cpe:/o:redhat:enterprise_linux:5

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/07/30

Vulnerability Publication Date: 2007/07/30

Exploitable With

Core Impact

Reference Information

CVE: CVE-2007-3387

BID: 25124

OSVDB: 38120

RHSA: 2007:0720

CWE: 189