CentOS 3 / 4 / 5 : bind (CESA-2007:0740)

Medium Nessus Plugin ID 25778

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated bind packages that fix a security issue are now available.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

ISC BIND (Berkeley Internet Name Domain) is an implementation of the DNS (Domain Name System) protocols.

A flaw was found in the way BIND generates outbound DNS query ids. If an attacker is able to acquire a finite set of query IDs, it becomes possible to accurately predict future query IDs. Future query ID prediction may allow an attacker to conduct a DNS cache poisoning attack, which can result in the DNS server returning incorrect client query data. (CVE-2007-2926)

Users of BIND are advised to upgrade to these updated packages, which contain backported patches to correct this issue.

Solution

Update the affected bind packages.

See Also

http://www.nessus.org/u?540b9401

http://www.nessus.org/u?0b847f63

http://www.nessus.org/u?cc652c10

http://www.nessus.org/u?56be2726

http://www.nessus.org/u?29385fec

http://www.nessus.org/u?ac7be649

http://www.nessus.org/u?73f3de8b

http://www.nessus.org/u?5e36de79

Plugin Details

Severity: Medium

ID: 25778

File Name: centos_RHSA-2007-0740.nasl

Version: 1.16

Type: local

Agent: unix

Published: 2007/07/27

Updated: 2019/10/03

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:bind, p-cpe:/a:centos:centos:bind-chroot, p-cpe:/a:centos:centos:bind-devel, p-cpe:/a:centos:centos:bind-libbind-devel, p-cpe:/a:centos:centos:bind-libs, p-cpe:/a:centos:centos:bind-sdb, p-cpe:/a:centos:centos:bind-utils, p-cpe:/a:centos:centos:caching-nameserver, cpe:/o:centos:centos:3, cpe:/o:centos:centos:4, cpe:/o:centos:centos:5

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/07/25

Vulnerability Publication Date: 2007/07/24

Reference Information

CVE: CVE-2007-2926

BID: 25037

RHSA: 2007:0740