CentOS 5 : tomcat (CESA-2007:0569)

Medium Nessus Plugin ID 25777

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated tomcat packages that fix two security issues and a packaging bug are now available for Red Hat Enterprise Linux 5.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

Tomcat is a servlet container for Java Servlet and JavaServer Pages (JSP) technologies.

Some JSPs within the 'examples' web application did not escape user provided data. If the JSP examples were accessible, this flaw could allow a remote attacker to perform cross-site scripting attacks (CVE-2007-2449).

Note: it is recommended the 'examples' web application not be installed on a production system.

The Manager and Host Manager web applications did not escape user provided data. If a user is logged in to the Manager or Host Manager web application, an attacker could perform a cross-site scripting attack (CVE-2007-2450).

Users of Tomcat should update to these erratum packages, which contain backported patches to correct these issues.

Solution

Update the affected tomcat packages.

See Also

http://www.nessus.org/u?e099de5b

http://www.nessus.org/u?8de0b974

Plugin Details

Severity: Medium

ID: 25777

File Name: centos_RHSA-2007-0569.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2007/07/27

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:tomcat5, p-cpe:/a:centos:centos:tomcat5-admin-webapps, p-cpe:/a:centos:centos:tomcat5-common-lib, p-cpe:/a:centos:centos:tomcat5-jasper, p-cpe:/a:centos:centos:tomcat5-jasper-javadoc, p-cpe:/a:centos:centos:tomcat5-jsp-2.0-api, p-cpe:/a:centos:centos:tomcat5-jsp-2.0-api-javadoc, p-cpe:/a:centos:centos:tomcat5-server-lib, p-cpe:/a:centos:centos:tomcat5-servlet-2.4-api, p-cpe:/a:centos:centos:tomcat5-servlet-2.4-api-javadoc, p-cpe:/a:centos:centos:tomcat5-webapps, cpe:/o:centos:centos:5

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/07/22

Reference Information

CVE: CVE-2007-2449, CVE-2007-2450

BID: 24475, 24476

RHSA: 2007:0569

CWE: 79