Mandrake Linux Security Advisory : ImageMagick (MDKSA-2007:147)

High Nessus Plugin ID 25750


The remote Mandrake Linux host is missing one or more security updates.


A number of vulnerabilities were discovered in how ImageMagick handles DCM and XWD image files. If a user were tricked into processing a specially crafted image file with an application that uses ImageMagick, an attacker could cause a heap-based buffer overflow and possibly execute arbitrary code with the user's privileges.

The updated packages have been patched to prevent these issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 25750

File Name: mandrake_MDKSA-2007-147.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2007/07/23

Modified: 2016/02/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ImageMagick, p-cpe:/a:mandriva:linux:ImageMagick-desktop, p-cpe:/a:mandriva:linux:ImageMagick-doc, p-cpe:/a:mandriva:linux:lib64Magick10.4.0, p-cpe:/a:mandriva:linux:lib64Magick10.4.0-devel, p-cpe:/a:mandriva:linux:lib64Magick10.7.0, p-cpe:/a:mandriva:linux:lib64Magick10.7.0-devel, p-cpe:/a:mandriva:linux:libMagick10.4.0, p-cpe:/a:mandriva:linux:libMagick10.4.0-devel, p-cpe:/a:mandriva:linux:libMagick10.7.0, p-cpe:/a:mandriva:linux:libMagick10.7.0-devel, p-cpe:/a:mandriva:linux:perl-Image-Magick, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/07/20

Reference Information

CVE: CVE-2007-1667, CVE-2007-1797

BID: 23300, 23347

OSVDB: 34107, 34108, 34688, 34689

MDKSA: 2007:147

CWE: 189