GLSA-200707-06 : XnView: Stack-based buffer overflow

Critical Nessus Plugin ID 25719


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200707-06 (XnView: Stack-based buffer overflow)

XnView is vulnerable to a stack-based buffer overflow while processing an XPM file with an overly long section string (greater than 1024 bytes).
Impact :

An attacker could entice a user to view a specially crafted XPM file with XnView that could trigger the vulnerability and possibly execute arbitrary code with the rights of the user running XnView.
Workaround :

There is no known workaround at this time.


No update appears to be forthcoming from the XnView developer and XnView is proprietary, so the XnView package has been masked in Portage. We recommend that users select an alternate graphics viewer and conversion utility, and unmerge XnView:
# emerge --unmerge xnview

See Also

Plugin Details

Severity: Critical

ID: 25719

File Name: gentoo_GLSA-200707-06.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/07/18

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xnview, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list, Host/Gentoo/arch

Patch Publication Date: 2007/07/11

Vulnerability Publication Date: 2007/04/22

Reference Information

CVE: CVE-2007-2194

OSVDB: 35235

GLSA: 200707-06