QuickTime < 7.2 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 25704


The remote Mac OS X host contains an application that is affected by multiple issues.


The version of QuickTime installed on the remote Mac OS X host is older than 7.2. Such versions contain several vulnerabilities that may allow an attacker to execute arbitrary code on the remote host if he can trick the user to open a specially crafted file with QuickTime.


Either use QuickTime's Software Update preference to upgrade to the latest version or manually upgrade to QuickTime 7.2 or later.

See Also




Plugin Details

Severity: High

ID: 25704

File Name: macosx_Quicktime72.nasl

Version: $Revision: 1.19 $

Type: local

Agent: macosx

Published: 2007/07/12

Modified: 2016/11/28

Dependencies: 15573

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: MacOSX/QuickTime/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/07/11

Vulnerability Publication Date: 2007/04/25

Reference Information

CVE: CVE-2007-2295, CVE-2007-2296, CVE-2007-2388, CVE-2007-2389, CVE-2007-2392, CVE-2007-2393, CVE-2007-2394, CVE-2007-2396, CVE-2007-2397, CVE-2007-2402

BID: 23650, 23652, 24221, 24222, 24873

OSVDB: 35575, 35576, 35577, 35578, 36131, 36132, 36133, 36134, 36135, 36136

CWE: 119, 189, 200, 264