Fedora Core 6 : libexif-0.6.15-2.fc6 (2007-614)

Medium Nessus Plugin ID 25619


The remote Fedora Core host is missing a security update.


The libexif package contains the EXIF library. Applications use this library to parse EXIF image files.

An integer overflow flaw was found in the way libexif parses EXIF image tags. If a victim opens a carefully crafted EXIF image file it could cause the application linked against libexif to execute arbitrary code or crash. (CVE-2007-4168)

Users of libexif should upgrade to these updated packages, which contain a backported patch and are not vulnerable to this issue.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected libexif, libexif-debuginfo and / or libexif-devel packages.

See Also


Plugin Details

Severity: Medium

ID: 25619

File Name: fedora_2007-614.nasl

Version: $Revision: 1.15 $

Type: local

Agent: unix

Published: 2007/06/29

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:libexif, p-cpe:/a:fedoraproject:fedora:libexif-debuginfo, p-cpe:/a:fedoraproject:fedora:libexif-devel, cpe:/o:fedoraproject:fedora_core:6

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2007/06/27

Reference Information

CVE: CVE-2006-4168

FEDORA: 2007-614