Nessus Windows < 3.0.6 GUI Unspecified XSS

Medium Nessus Plugin ID 25612


An application running on the remote host is affected by a cross-site scripting vulnerability.


According to its self-reported version number, the Tenable Nessus application running on the remote host is affected by a cross-site scripting (XSS) vulnerability due to a failure to properly sanitize user-supplied input before using it to generate dynamic content. An unauthenticated, remote attacker can exploit this issue to inject arbitrary HTML or script code into a user's browser to be executed within the security context of the affected host.


Upgrade to Nessus for Windows version 3.0.6 or later.

See Also

Plugin Details

Severity: Medium

ID: 25612

File Name: nessus_windows_gui_xss.nasl

Version: $Revision: 1.22 $

Type: local

Agent: windows

Family: Windows

Published: 2007/06/29

Modified: 2017/02/23

Dependencies: 13855

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:nessus:nessus

Required KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2007/06/19

Reference Information

CVE: CVE-2007-3546

BID: 24677

OSVDB: 37011

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990