GLSA-200706-08 : emul-linux-x86-java: Multiple vulnerabilities

Critical Nessus Plugin ID 25593

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200706-08 (emul-linux-x86-java: Multiple vulnerabilities)

Chris Evans of the Google Security Team has discovered an integer overflow in the ICC parser, and another vulnerability in the BMP parser. An unspecified vulnerability involving an 'incorrect use of system classes' was reported by the Fujitsu security team.
Impact :

A remote attacker could entice a user to open a specially crafted image, possibly resulting in the execution of arbitrary code with the privileges of the user running Emul-linux-x86-java. They also could entice a user to open a specially crafted BMP image, resulting in a Denial of Service. Note that these vulnerabilities may also be triggered by a tool processing image files automatically.
Workaround :

There is no known workaround at this time.

Solution

All Emul-linux-x86-java users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-emulation/emul-linux-x86-java-1.5.0.11'

See Also

https://security.gentoo.org/glsa/200706-08

Plugin Details

Severity: Critical

ID: 25593

File Name: gentoo_GLSA-200706-08.nasl

Version: 1.16

Type: local

Published: 2007/06/27

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:emul-linux-x86-java, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/06/26

Vulnerability Publication Date: 2007/05/01

Reference Information

CVE: CVE-2007-2435, CVE-2007-2788, CVE-2007-2789

GLSA: 200706-08

CWE: 189, 264, 399