Debian DSA-1312-1 : libapache-mod-jk - programming error

Medium Nessus Plugin ID 25556

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that the Apache 1.3 connector for the Tomcat Java servlet engine decoded request URLs multiple times, which can lead to information disclosure.

Solution

Upgrade the libapache-mod-jk package.

For the oldstable distribution (sarge) this problem has been fixed in version 1.2.5-2sarge1. An updated package for powerpc is not yet available due to problems with the build host. It will be provided later.

For the stable distribution (etch) this problem has been fixed in version 1.2.18-3etch1.

See Also

https://www.debian.org/security/2007/dsa-1312

Plugin Details

Severity: Medium

ID: 25556

File Name: debian_DSA-1312.nasl

Version: 1.17

Type: local

Agent: unix

Published: 2007/06/21

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libapache-mod-jk, cpe:/o:debian:debian_linux:3.1, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2007/06/18

Reference Information

CVE: CVE-2007-1860

DSA: 1312

CWE: 20, 22