RHEL 2.1 / 3 / 4 / 5 : fetchmail (RHSA-2007:0385)

Low Nessus Plugin ID 25454

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

An updated fetchmail package that fixes a security bug is now available for Red Hat Enterprise Linux 2.1, 3, 4 and 5.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

Fetchmail is a remote mail retrieval and forwarding utility intended for use over on-demand TCP/IP links, like SLIP or PPP connections.

A flaw was found in the way fetchmail processed certain APOP authentication requests. By sending certain responses when fetchmail attempted to authenticate against an APOP server, a remote attacker could potentially acquire certain portions of a user's authentication credentials. (CVE-2007-1558)

All users of fetchmail should upgrade to this updated package, which contains a backported patch to correct this issue.

Solution

Update the affected fetchmail and / or fetchmailconf packages.

See Also

https://access.redhat.com/security/cve/cve-2007-1558

http://fetchmail.berlios.de/fetchmail-SA-2007-01.txt

https://access.redhat.com/errata/RHSA-2007:0385

Plugin Details

Severity: Low

ID: 25454

File Name: redhat-RHSA-2007-0385.nasl

Version: 1.21

Type: local

Agent: unix

Published: 2007/06/07

Updated: 2019/09/17

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.6

Temporal Score: 2

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:fetchmail, p-cpe:/a:redhat:enterprise_linux:fetchmailconf, cpe:/o:redhat:enterprise_linux:2.1, cpe:/o:redhat:enterprise_linux:3, cpe:/o:redhat:enterprise_linux:4, cpe:/o:redhat:enterprise_linux:4.5, cpe:/o:redhat:enterprise_linux:5

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/06/07

Vulnerability Publication Date: 2007/04/16

Reference Information

CVE: CVE-2007-1558

BID: 23257

RHSA: 2007:0385