FlipViewer ActiveX Control < 4.1 Buffer Overflow Vulnerabilities

High Nessus Plugin ID 25442


The remote Windows host has an ActiveX control that is susceptible to buffer overflow vulnerabilities.


The Windows remote host contains the FlipViewer ActiveX control, which is used for viewing electronic documents.

The version of this ActiveX control on the remote host reportedly contains multiple stack-based buffer overflow vulnerabilities. A remote attacker may be able to leverage these issues to execute arbitrary code on the remote host subject to the privileges of the current user.


Upgrade to version 4.1 or later of the control.

Plugin Details

Severity: High

ID: 25442

File Name: flipviewer_activex_41_overflows.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2007/06/07

Modified: 2015/01/12

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/06/05

Vulnerability Publication Date: 2007/06/05

Exploitable With

Metasploit (FlipViewer FViewerLoading ActiveX Control Buffer Overflow)

Reference Information

CVE: CVE-2007-2919

BID: 24328

OSVDB: 37042

CERT: 449089