GLSA-200706-01 : libexif: Integer overflow vulnerability

High Nessus Plugin ID 25438


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200706-01 (libexif: Integer overflow vulnerability)

Victor Stinner reported an integer overflow in the exif_data_load_data_entry() function from file exif-data.c while handling Exif data.
Impact :

An attacker could entice a user to process a file with specially crafted Exif extensions with an application making use of libexif, which will trigger the integer overflow and potentially execute arbitrary code or crash the application.
Workaround :

There is no known workaround at this time.


All libexif users should upgrade to the latest version. Please note that users upgrading from '<=media-libs/libexif-0.6.13' should also run revdep-rebuild after their upgrade.
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/libexif-0.6.15' # revdep-rebuild --library=/usr/lib/

See Also

Plugin Details

Severity: High

ID: 25438

File Name: gentoo_GLSA-200706-01.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/06/07

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libexif, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/06/05

Vulnerability Publication Date: 2007/05/11

Reference Information

CVE: CVE-2007-2645

OSVDB: 35978

GLSA: 200706-01