GLSA-200705-21 : MPlayer: Two buffer overflows

High Nessus Plugin ID 25360


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200705-21 (MPlayer: Two buffer overflows)

A buffer overflow has been reported in the DMO_VideoDecoder_Open() function in file loader/dmo/DMO_VideoDecoder.c. Another buffer overflow has been reported in the DS_VideoDecoder_Open() function in file loader/dshow/DS_VideoDecoder.c.
Impact :

A remote attacker could entice a user to open a specially crafted video file, potentially resulting in the execution of arbitrary code with the privileges of the user running MPlayer.
Workaround :

There is no known workaround at this time.


All MPlayer users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-video/mplayer-1.0.20070321'

See Also

Plugin Details

Severity: High

ID: 25360

File Name: gentoo_GLSA-200705-21.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/06/01

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mplayer, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/05/30

Vulnerability Publication Date: 2007/03/08

Reference Information

CVE: CVE-2007-1246, CVE-2007-1387

OSVDB: 33995, 33996

GLSA: 200705-21

CWE: 119