RHEL 5 : ipsec-tools (RHSA-2007:0342)

Medium Nessus Plugin ID 25330


The remote Red Hat host is missing a security update.


Updated ipsec-tools packages that fix a denial of service flaw in racoon are now available for Red Hat Enterprise Linux 5.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

The ipsec-tools package is used in conjunction with the IPsec functionality in the linux kernel and includes racoon, an IKEv1 keying daemon.

A denial of service flaw was found in the ipsec-tools racoon daemon.
It was possible for a remote attacker, with knowledge of an existing ipsec tunnel, to terminate the ipsec connection between two machines.

Users of ipsec-tools should upgrade to these updated packages, which contain a backported patch that resolves this issue.


Update the affected ipsec-tools package.

See Also



Plugin Details

Severity: Medium

ID: 25330

File Name: redhat-RHSA-2007-0342.nasl

Version: $Revision: 1.17 $

Type: local

Agent: unix

Published: 2007/05/25

Modified: 2016/12/29

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:ipsec-tools, cpe:/o:redhat:enterprise_linux:5

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2007/05/17

Vulnerability Publication Date: 2007/04/06

Reference Information

CVE: CVE-2007-1841

OSVDB: 34728

RHSA: 2007:0342