RHEL 5 : xorg-x11-apps and libX11 (RHSA-2007:0157)

High Nessus Plugin ID 25326


The remote Red Hat host is missing one or more security updates.


Updated xorg-x11-apps and libX11 packages that fix a security issue are now available for Red Hat Enterprise Linux 5.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

X.org is an open source implementation of the X Window System. It provides the basic low-level functionality that full-fledged graphical user interfaces are designed upon.

An integer overflow flaw was found in the X.org XGetPixel() function.
Improper use of this function could cause an application calling it to function improperly, possibly leading to a crash or arbitrary code execution. (CVE-2007-1667)

Users of the X.org X11 server should upgrade to these updated packages, which contain a backported patch and are not vulnerable to this issue.


Update the affected libX11, libX11-devel and / or xorg-x11-apps packages.

See Also



Plugin Details

Severity: High

ID: 25326

File Name: redhat-RHSA-2007-0157.nasl

Version: $Revision: 1.19 $

Type: local

Agent: unix

Published: 2007/05/25

Modified: 2016/12/29

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:libX11, p-cpe:/a:redhat:enterprise_linux:libX11-devel, p-cpe:/a:redhat:enterprise_linux:xorg-x11-apps, cpe:/o:redhat:enterprise_linux:5

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/04/16

Vulnerability Publication Date: 2007/04/03

Reference Information

CVE: CVE-2007-1667

BID: 23300

OSVDB: 34107, 34108

RHSA: 2007:0157

CWE: 189