GLSA-200705-14 : XScreenSaver: Privilege escalation

Medium Nessus Plugin ID 25235


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200705-14 (XScreenSaver: Privilege escalation)

XScreenSaver incorrectly handles the results of the getpwuid() function in drivers/lock.c when using directory servers during a network outage.
Impact :

A local user can crash XScreenSaver by preventing network connectivity if the system uses a remote directory service for credentials such as NIS or LDAP, which will unlock the screen.
Workaround :

There is no known workaround at this time.


All XScreenSaver users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-misc/xscreensaver-5.02'

See Also

Plugin Details

Severity: Medium

ID: 25235

File Name: gentoo_GLSA-200705-14.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/05/16

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xscreensaver, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/05/13

Vulnerability Publication Date: 2007/05/03

Reference Information

CVE: CVE-2007-1859

OSVDB: 35531

GLSA: 200705-14

CWE: 287