Mandrake Linux Security Advisory : vim (MDKSA-2007:101)

High Nessus Plugin ID 25191


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability in vim 7.0's modeline processing capabilities was discovered where a user with modelines enabled could open a text file containing a carefully crafted modeline, executing arbitrary commands as the user running vim.

Updated packages have been patched to prevent this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 25191

File Name: mandrake_MDKSA-2007-101.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/05/10

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:vim-X11, p-cpe:/a:mandriva:linux:vim-common, p-cpe:/a:mandriva:linux:vim-enhanced, p-cpe:/a:mandriva:linux:vim-minimal, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/05/09

Reference Information

CVE: CVE-2007-2438

MDKSA: 2007:101