MS07-023 / MS07-024 / MS07-025: Vulnerabilities in Microsoft Office Allow Remote Code Execution (934233 / 934232 / 934873) (Mac OS X)

High Nessus Plugin ID 25173


An application installed on the remote Mac OS X host is affected by multiple remote code execution vulnerabilities.


The remote host is running a version of Microsoft Office that is affected by various flaws that may allow arbitrary code to be run.

To succeed, the attacker would have to send a rogue file to a user of the remote computer and have him open it with Microsoft Word, Excel or another Office application.


Microsoft has released a set of patches for Office for Mac OS X.

See Also

Plugin Details

Severity: High

ID: 25173

File Name: macosx_ms_office_may2007.nasl

Version: 1.27

Type: local

Agent: macosx

Published: 2007/05/09

Modified: 2017/08/30

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:office:2004::mac

Required KB Items: Host/MacOSX/packages

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/05/08

Vulnerability Publication Date: 2007/05/09

Reference Information

CVE: CVE-2007-0035, CVE-2007-0215, CVE-2007-1202, CVE-2007-1203, CVE-2007-1214, CVE-2007-1747

BID: 23760, 23779, 23780, 23804, 23826, 23836

OSVDB: 34387, 34388, 34393, 34394, 34395, 34396

MSFT: MS07-023, MS07-024, MS07-025

MSKB: 934232, 934233, 934873

CWE: 399