Trend Micro ServerProtect EarthAgent RPC Request Remote Buffer Overflow

Critical Nessus Plugin ID 25172


The remote service is vulnerable to a remote buffer overflow attack.


The remote version of Trend Micro ServerProtect is vulnerable to a stack overflow involving its EarthAgent service. An unauthenticated, remote attacker may be able to leverage this issue with specially- crafted RPC requests to execute arbitrary code on the remote host.

Note that by default, Trend Micro services run with LocalSystem privileges.


Apply Security Patch 2 - Build 1174 or later.

See Also

Plugin Details

Severity: Critical

ID: 25172

File Name: trendmicro_serverprotect_earthagent_overflow.nasl

Version: $Revision: 1.14 $

Type: remote

Agent: windows

Family: Windows

Published: 2007/05/09

Modified: 2016/11/03

Dependencies: 24679

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:trend_micro:serverprotect:5.58 and previous versions

Required KB Items: Antivirus/TrendMicro/ServerProtect

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/04/03

Vulnerability Publication Date: 2007/05/08

Exploitable With


Core Impact

Metasploit (Trend Micro ServerProtect 5.58 EarthAgent.EXE Buffer Overflow)

Reference Information

CVE: CVE-2007-2508

BID: 23866

OSVDB: 35789