GLSA-200705-04 : Apache mod_perl: Denial of Service

Medium Nessus Plugin ID 25154


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200705-04 (Apache mod_perl: Denial of Service)

Alex Solvey discovered that the 'path_info' variable used in file (mod_perl 2.x) or file (mod_perl 1.x), is not properly escaped before being processed.
Impact :

A remote attacker could send a specially crafted URL to the vulnerable server, possibly resulting in a massive resource consumption.
Workaround :

There is no known workaround at this time.


All mod_perl 1.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apache/mod_perl-1.30' All mod_perl 2.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apache/mod_perl-2.0.3-r1'

See Also

Plugin Details

Severity: Medium

ID: 25154

File Name: gentoo_GLSA-200705-04.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/05/03

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mod_perl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/05/02

Vulnerability Publication Date: 2007/03/22

Reference Information

CVE: CVE-2007-1349

BID: 23192

OSVDB: 34540, 34541

GLSA: 200705-04

CWE: 399