Mandrake Linux Security Advisory : sqlite (MDKSA-2007:091)

High Nessus Plugin ID 25114


The remote Mandrake Linux host is missing one or more security updates.


A buffer overflow in sqlite could allow context-dependent attackers to execute arbitrary code via an empty value of the 'in' parameter.

Updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 25114

File Name: mandrake_MDKSA-2007-091.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2007/04/30

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64sqlite0, p-cpe:/a:mandriva:linux:lib64sqlite0-devel, p-cpe:/a:mandriva:linux:lib64sqlite0-static-devel, p-cpe:/a:mandriva:linux:libsqlite0, p-cpe:/a:mandriva:linux:libsqlite0-devel, p-cpe:/a:mandriva:linux:libsqlite0-static-devel, p-cpe:/a:mandriva:linux:sqlite-tools, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/04/18

Reference Information

CVE: CVE-2007-1888

MDKSA: 2007:091