GLSA-200704-19 : Blender: User-assisted remote execution of arbitrary code

High Nessus Plugin ID 25107


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200704-19 (Blender: User-assisted remote execution of arbitrary code)

Stefan Cornelius of Secunia Research discovered an insecure use of the 'eval()' function in
Impact :

A remote attacker could entice a user to open a specially crafted Blender file (.kmz or .kml), resulting in the execution of arbitrary Python code with the privileges of the user running Blender.
Workaround :

There is no known workaround at this time.


All Blender users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-gfx/blender-2.43'

See Also

Plugin Details

Severity: High

ID: 25107

File Name: gentoo_GLSA-200704-19.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/04/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:blender, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/04/23

Vulnerability Publication Date: 2007/03/01

Reference Information

CVE: CVE-2007-1253

OSVDB: 33836

GLSA: 200704-19

CWE: 94